Savannah Cat Chat - THE Place for Savannah Cat Talk

Welcome to the Savannah Cat Chat Forum! Our forum has been in existence since 2012 and is the only one of its kind. We were here, serving the savannah cat community before Facebook and Instagram! Register for a free account today to become a member! Please use an email program other than Hotmail, since Hotmail accounts are blacklisted by many servers and ISP's. Once signed in, you'll be able to participate on this site in some of the forums by adding your own topics and posts. But in order to take advantage of the full features, such as a private inbox as well as connect with other members ad access some of the larger topics, a donation of $2.99/mo or $25/yr is requested. This will allow us to continue running this forum!

NEW FORUM DESIGN

Hippy

Site Supporter
#42
Was private messages, nothing with the forum posting..
Sent you a text pm and it worked
Used to say I didn't have the privileges to send PM's..
I was able to get them but not reply either..

Anyway seems to be good now
Thanks

Sent from my SM-G955U using Tapatalk
 

Sean

Site Supporter
#43
I haven't received any emails from you David! I have received others...let me look into it and try to figure out what is going on. Can you send an email to admin@savannahcatchat.com and let me see if I receive it.


Sent from my iPhone using Tapatalk
Paige you should get one from my email account also.
Thanks

EDIT I has set a few emails to the admin when i could not get in.
One thought are you sure they changed all the email address on all of the pages?
 

David-z

Savannah Kitten
#44
Did you have the 2 step verification activated on your account Sean?
That's what's keeping me out of my other acount no emails from the site go through to it.
Checked all settings everything that blocks emails like spam stuff is turned off. Maybe it's just cause it's a cox.net email.
 

Sean

Site Supporter
#46
Well here is how I have some things setup and I checked and the Two Step if disabled.
Screen Shot 2019-05-21 at 3.39.48 AM.png
Screen Shot 2019-05-21 at 3.40.07 AM.png

So with all of that checked I should be getting emails. Yet I still am not getting nay.